The Leostream Gateway requires packages that are available in EPEL.    The following error is displayed if the EPEL packages are not available.

No match for argument: epel-release

Error: Unable to find a match: epel-release

Updating Subscription Management repositories.

Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs) 50 kB/s | 2.4 kB 00:00

Red Hat Enterprise Linux 8 for x86_64 - AppStream (RPMs) 53 kB/s | 2.8 kB 00:00

Red Hat Satellite Tools 6.8 for RHEL 8 x86_64 (RPMs) 38 kB/s | 2.1 kB 00:00

Error:

 Problem: cannot install the best candidate for the job

  - nothing provides mod_perl needed by leostream-gateway-2022.1.0-6.x86_64

  - nothing provides libguac >= 1.1.0 needed by leostream-gateway-2022.1.0-6.x86_64

  - nothing provides libguac-client-rdp >= 1.1.0 needed by leostream-gateway-2022.1.0-6.x86_64

  - nothing provides libguac-client-ssh >= 1.1.0 needed by leostream-gateway-2022.1.0-6.x86_64

  - nothing provides libguac-client-vnc >= 1.1.0 needed by leostream-gateway-2022.1.0-6.x86_64

  - nothing provides openvpn needed by leostream-gateway-2022.1.0-6.x86_64

(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Please reboot to start the Leostream gateway

 

Resolution

You can resolve this error by installing the EPEL packages prior to installing the Leostream Gateway

sudo dnf -y install epel-release 

sudo curl http://downloads.leostream.com/gateway/sh | bash

sudo /sbin/reboot